Aftermarket stator? - Triumph675.Net Forums
General 675 discussion Anything related to the Triumph 675 model(s), and miscellaneous motorcycle talk.

 
Thread Tools Display Modes
post #1 of 6 Old 11-08-12, 01:45 Thread Starter
luciano136
Senior Member
 
Join Date: Jul 2009
Location: OC, CA
Posts: 809
Thanks: 7
Thanked 2 Times in 2 Posts
Aftermarket stator?

Are there any better aftermarket stators available? I don't ever want to rush off the fwy again in the dark because the damn thing fails!! Not a fun experience to say the least!



Sent from my iPhone using Motorcycle.com App
luciano136 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 11-08-12, 02:25
pyroking339
Senior Member
 
pyroking339's Avatar
 
Join Date: Jun 2008
Location: Ann Arbor, MI
Posts: 968
Thanks: 1
Thanked 0 Times in 0 Posts
Are you sure the stator failure wasn't caused by a failed regulator/rectifier unit?
pyroking339 is online now  
post #3 of 6 Old 11-08-12, 03:00 Thread Starter
luciano136
Senior Member
Threadstarter Threadstarter
 
Join Date: Jul 2009
Location: OC, CA
Posts: 809
Thanks: 7
Thanked 2 Times in 2 Posts
I need to test to be positive but the r/r is a unit from an R1 that I installed a little over a year ago. I think those are pretty reliable.

The stator is still the original and I have 23k mi on the bike, so I figured chances are high that's the culprit.

Pretty bummed; now I have to sit in traffic in my car :(.


Sent from my iPhone using Motorcycle.com App
luciano136 is offline  
post #4 of 6 Old 11-09-12, 16:45
Karl
Member
 
Karl's Avatar
 
Join Date: Dec 2010
Location: Auckland
Posts: 631
Thanks: 0
Thanked 0 Times in 0 Posts
My one is from regulator rectifier.com, be over 20,000km of use and its still doing the job.
Also has the pickup too, handy to have another one about just in case…
Karl is offline  
post #5 of 6 Old 11-09-12, 18:18
fourthreesix
Junior Member
 
fourthreesix's Avatar
 
Join Date: Jun 2010
Location: Pittsburg, CA
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
I replaced my stator with a Rick's unit. It was a total pain installing due to the grommet that is on the unit not sealing properly, but since that's been fixed it's been working like a champ. Just couldn't justify paying the high amount for the OEM stator.

Gordon

08 Street Triple
fourthreesix is offline  
post #6 of 6 Old 11-14-12, 23:51 Thread Starter
luciano136
Senior Member
Threadstarter Threadstarter
 
Join Date: Jul 2009
Location: OC, CA
Posts: 809
Thanks: 7
Thanked 2 Times in 2 Posts
A new aftermarket one is being installed. The OEM one fried and took out my 1y old R/R in the process...


Sent from my iPhone using Motorcycle.com App
luciano136 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome