Racing starts - Page 3 - Triumph675.Net Forums
Riding Skills Tips, lessons, experiences, etc. Beginner, intermediate and advanced.

Thread Tools Display Modes
post #21 of 22 Old 11-10-12, 20:34
Senior Member
wavrdr's Avatar
Join Date: Feb 2009
Location: On the box!!
Posts: 1,131
Thanks: 50
Thanked 40 Times in 19 Posts
I stage the bike between 8-9k rpm and then slowly fade the clutch when the flag drops with the rpm hovering around 10k.....

The 675 is a difficult bike to launch IMHO, as it'll either bog or wheelie to much. I've had tons of bad starts and a few really good ones...Don't sweat it, just pass them exiting turn 1!

CCS Florida expert #52

Sidi boots-Forcefield Armor-Amsoil
wavrdr is offline  
Sponsored Links
post #22 of 22 Old 11-11-12, 14:48 Thread Starter
Senior Member
Threadstarter Threadstarter
Rink675's Avatar
Join Date: Aug 2012
Location: Minneapolis
Posts: 909
Thanks: 0
Thanked 0 Times in 0 Posts
Yea I am planning on checking the clutch plates and see how they are looking.

2007 Triumph 675 Race Bike
Rink675 is offline  
Sponsored Links


Quick Reply

Register Now

In order to be able to post messages on the Triumph675.Net Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome