Power/starting problem after headlight and guage R&R - Triumph675.Net Forums
Home Forum Browse Members Calendar Register Today!  
New Posts Faq / Help? XBOX Live Modifications Classifieds
   
Not A Member Yet? Register today and become part of the community.
Go Back   Triumph675.Net Forums > Daytona 675 & Street Triple 675 Global Forums > Maintenance and repair > Repair/Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-08-12, 03:30   #1
odyssey
Junior Member
 
Join Date: Aug 2012
Location: Brisbane
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Power/starting problem after headlight and guage R&R

I took the headlight and gauge cluster off my '07 Daytona to swap to race fairings and now have an odd problem.

The bike ran fine prior to this. Now the indicator lights on the gauges show ok (high beam, indicators etc) but the gauges themselves aren't working and there's no power to starter etc. Neutral light, engine light etc aren't working. All plugs are connected to the gauge cluster, battery is fully charged and fuses are ok. Kill switch is in run position. I pulled the main plug out of the gauges cluster to check it and when I put it back in the red LED on the cluster blinked once but the problem persists.

Any ideas?

Thanks
Status: Offline
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 11-08-12, 21:30   #2
odyssey
Junior Member
 
Join Date: Aug 2012
Location: Brisbane
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Problem solved- kill switch plug (down on the side of the radiator) wasn't all the way in.
Status: Offline
 
Reply With Quote
Old 11-09-12, 03:36   #3
Ruby Racing
BOTM Winner
 
Ruby Racing's Avatar
 
Join Date: Jan 2009
Location: Jersey, Channel Islands
Posts: 2,203
Thanks: 0
Thanked 19 Times in 17 Posts
Default

Glad we could help.
__________________

To read about the transformation click > Project Trixie Transformation

For comparison photo of old R/R with new improved R/R under recall of 2012 click > R/R Comparison Photos
Status: Online
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Forum SEO by Zoints
Copyright 2009 TRIUMPH675.NET Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum