Triumph675.Net Forums - View Profile: froghammer

froghammer froghammer is offline

Member

  Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. richpc70
    06-02-10 23:26
    richpc70
    hi froghammer have a question about my 675 ive just bought hope you can help. its been sitting for the last week while i was on holidays over seas now ive gone to start it and the engine management malfunction indicator light is on and it just clicks when i hit the start button. i know the battery is fully charged and it started before my hols and hasnt been touched for the week i was away any help would be great cheers Richard
  2. SSdan
    05-21-10 01:30
    SSdan
    just out of curiosity is that your helmet and jacket in your avatar pic? ive really been looking for some cool, all white and black gear, seems most of the decent looking white/black color schemes are the womans clothes, anyways that pic in your avatar is exactly the look im going for, looks to be scorpion? if you could let me know that would be great, thanks

  About Me

  • About froghammer
    City
    Toronto
    Occupation
    Photographer

  Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: 02-05-13 09:14
  • Join Date: 06-18-09
  • Referrals: 0

  Friends

Showing Friends 1 to 2 of 2
  • FLuK28
    • FLuK28 is offline
  • umicheng
    • umicheng is offline
    • Send a message via AIM to umicheng

  Mentions

No results to display...

  Quotes

No results to display...
 
For the best viewing experience please update your browser to Google Chrome